Sample add-ins not working

Jan 30, 2014 at 8:18 AM
Edited Jan 30, 2014 at 8:31 AM
Hi All
After reinstalling the Office, the sample add-ins are not loaded on my development machine. I have tried Outlook and Word add-ins with 3.5 and 4.0 framework. The add-ins are registered successfully (checked in registry), but not loaded in the Outlook and Word.

Here is the registry entry:
[HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\AddIns\SimpleOutlookCS35.Addin]
"LoadBehavior"=dword:00000003
"FriendlyName"="NetOfficeCS35 Sample Outlook Addin"
"Description"="This Addin shows you the COMAddin base class from the NetOffice Tools"

The COM add-in settings dialog shows Load behavior is Unloaded, the checkbox is unchecked and not possible to activate it.
The samples worked with Office 2010 and 32 bit 2013.
I tried to log with FusionLog, but nothing is logged related to sample add-ins :(.
OS: Windows 7, Office version: Office 2013, 64 bit, Built with Microsoft Visual Studio Premium 2012

Thanks for your help
Jan 30, 2014 at 11:13 AM
Looks like some startup error. You need to find the exception during the addin startup which inactivates it again.
Set the environment variable VSTO_SUPPRESSDISPLAYALERTS = 0

Please follow the instructions in this link
http://www.scinaptic.com/support/0053.html
Jan 31, 2014 at 9:21 AM
It has been solved in the meantime, the reason was that the code had to be complied as 64bit, AnyCPU did not work. What a bigger issue was that there was no clue, no error message, log, etc.
Jan 31, 2014 at 11:35 AM
thanks, my add-in is working now.