.Net 2.0

Sep 24, 2011 at 10:00 AM

I get the following build error when adding latest NetOffice references in my .Net 2.0 solution. According to the docs v2.0 is supported ?

C:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.Common.targets(1490,5): warning MSB3258: The primary reference "OfficeApi" could not be resolved because it has an indirect dependency on the .NET Framework assembly "mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" which has a higher version "4.0.0.0" than the version "2.0.0.0" in the current target framework.

Coordinator
Sep 24, 2011 at 8:38 PM

hello wjb,

i dont have these warning all the time. looks like i forget to remove a reference. netoffice supports .NET 2.0 of course.
all examples in repository source code are based and testet in .net 2.0. this is also my primary .net version personaly.
do you use VB or C#? which IDE? NetOffice 1.2?

*sebastian

 

Sep 25, 2011 at 7:28 AM

Ouch - I had copied the dll's from a 4.0 project to a 2.0 project. Everything works fine with the right dll's. Sorry for the confusion.