This project has moved. For the latest updates, please go here.

Developer Toolbox 1.2

Jul 26, 2013 at 7:11 AM
Hello,
i'm here for the first time.
Working with Win7 64bit and VS 2010 express

First:
I downloaded the devloper Toolbox 1.2 and NetOffice 1.6, but i cant find any information what i have to do with the download. Is ther anything to install? Or can i extract the download in any place? I have to remove first the older Version (1.1)? Do i need both downloads or is 1.6 integrated in Developer toolbox?

Second:
I placed the developer toolbox anywhere and try to start developer toolbox.exe but i got an error: 1 | Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt. | NullReferenceException | Void InitStreamInput(System.Uri, System.String, System.IO.Stream, Byte[], Int32, System.Text.Encoding)
Coordinator
Jul 26, 2013 at 1:22 PM
hello,

sounds like an issue, gimme 1 hour the clearify the situation.

*sry
Sebastian
Coordinator
Jul 26, 2013 at 1:33 PM
Edited Jul 26, 2013 at 1:34 PM
you dont need anything to do. delete the old toolbox and start the DeveloperToolbox.exe (xcopy deployment)

update: its a bug in the settings file handler.
i do an update today for the toolbox.

hotfix:
got to the directory Environment.GetFolderPath(Environment.SpecialFolder.LocalApplicationData)
(it's C:\AppData in Win7, not sure...) and replace the content of the file DeveloperToolbox.Settings.xml

with:
<?xml version="1.0" encoding="utf-8"?>
<Application StartMinimized="False" MinimizeToTray="False" StartWithWindows="False" Language="0" Version="1.2.0.0">
  <Controls>
    <ApplicationObserver>
      <Control>
        <Excel Enabled="True" />
        <Winword Enabled="True" />
        <Outlook Enabled="False" />
        <PowerPnt Enabled="True" />
        <MsAccess Enabled="False" />
        <Project Enabled="False" />
        <Visio Enabled="False" />
        <HotKey Enabled="False" Keys="131153" />
        <Tray Enabled="False" />
      </Control>
    </ApplicationObserver>
    <RegistryEditor>
      <AskBeforeDelete>false</AskBeforeDelete>
    </RegistryEditor>
    <AddinGuard>
      <Active>false</Active>
      <SetLoadBehavior>false</SetLoadBehavior>
      <TrayNotify>false</TrayNotify>
    </AddinGuard>
    <OfficeCompatibility>
    </OfficeCompatibility>
    <OutlookSecurity>
      <SupressEnabled>false</SupressEnabled>
    </OutlookSecurity>
  </Controls>
</Application>
hope this helps
Sebastian
Coordinator
Jul 26, 2013 at 2:04 PM
an update is available for the Toolbox 1.2
the source is also available in the download.

*please give me a request the update is working fine for you.
Sebastian
Jul 26, 2013 at 2:06 PM
Sorry, but an DeveloperToolbox.Settings.xml doesn't exist
Coordinator
Jul 26, 2013 at 2:14 PM
please try the updated toolbox.

*thx
Sebastian
Jul 26, 2013 at 2:22 PM
Hello,
i do the download but now i got a new error while starting:
1 | Es wurde versucht, eine Assembly von einer Netzwerkadresse zu laden, was in früheren Versionen von .NET Framework zum Ausführen der Assembly als Sandkastenassembly geführt hätte. In dieser Version von .NET Framework wird die CAS-Richtlinie standardmäßig nicht aktiviert, dieser Ladevorgang kann daher gefährlich sein. Wenn Sie nicht beabsichtigen, durch diesen Ladevorgang eine Sandkastenassembly zu erstellen, aktivieren Sie den loadFromRemoteSources-Schalter. Weitere Informationen finden Sie unter "http://go.microsoft.com/fwlink/?LinkId=155569". | NotSupportedException | Void .ctor()

and the Programm canceld.
Coordinator
Jul 26, 2013 at 2:31 PM
hmm, das sehe ich das erste mal.
liegt das tool auf einem netzlaufwerk oder usb stick?
von dort darf man .net assemblies nicht ohne weiteres ausführen.

Sebastian
Jul 26, 2013 at 2:42 PM
Nein, liegt im Ordner "C:\Programme(x86)\Developer Toolbox\
Die vorhergehende Version startete nach Bestätigen der Fehlermeldung, bei der jetzigen bricht das Programm ab (auch mit rechtsklick ...als Administrator ausführen)
Coordinator
Jul 26, 2013 at 3:10 PM
welche .net version(en) hast du denn installiert ?
Ich habs inzwischen sogar auf einem 64 bit 2008R2 server getestet, immer ohne probleme -.-
Jul 26, 2013 at 3:44 PM

Siehe Anlage

Gruß

Hans

Von: SebastianDotNet [email removed]
Gesendet: Freitag, 26. Juli 2013 17:11
An: [email removed]
Betreff: Re: Developer Toolbox 1.2 [netoffice:451475]

From: SebastianDotNet

welche .net version(en) hast du denn installiert ?
Ich habs inzwischen sogar auf einem 64 bit 2008R2 server getestet, immer ohne probleme -.-

Jul 26, 2013 at 3:46 PM
Hab dir E-Mail mit Bild der installierten Net gesendet
Ist Net 4.0

Hans
Jul 26, 2013 at 3:48 PM
Toolbox 1.1 läuft problemlos

Hans
Coordinator
Jul 26, 2013 at 4:24 PM
Bei mir ist bis jetzt keine E-Mail angekommen.

Sebastian
Jul 26, 2013 at 4:25 PM
OK, habs jetzt auf einer anderen Win7/64 bit Maschine probiert, läuft problemlos, weiss nicht warum..hmm. das beschäftigt mich jetzt wieder
Jul 26, 2013 at 4:29 PM
hab auf die email geantwortet. Adresse : netoffice@discussions.codeplex.com